Skip to content

solved

6月 12, 2009

追記:
今日の

ruby-1.8.7.160_1,1                  <   needs updating (index has 1.8.7.160_2,1)

によってこの問題は完全に解消されたようです。

Pythonアップデート問題ですが、昨日はウマくいかなかったことが、全く同じ手順で今日ウマくいってしまったようで、ログを読み直してもわからないけれど、一応解決したということで。

# portmaster -o lang/python26 lang/python25

===>>> Currently installed version: python25-2.5.4_1
===>>> Port directory: /usr/ports/lang/python26

===>>> Gathering distinfo list for installed ports

cd /usr/ports/lang/python26 && /usr/bin/make config;

ってことで、無事にmakeされちゃいました。
ただ、全部終ってから念のために、

 pkgdb -aF
--->  Checking the package registry database
[Updating the pkgdb  in /var/db/pkg ... - 68 packages found (-1 +2) (...).. done]
# portversion -vL=
[Updating the portsdb  in /usr/ports ... - 20346 port entries found ** Stale lock file was found. Removed.
.........1000.........2000.........3000.........4000.........5000.........6000.........7000.........8000.........9000.........10000.........11000.........12000.........13000.........14000.........15000.........16000.........17000.........18000.........19000.........20000... ..... done]
python-2.5,2                <  needs updating (port has 2.6,2) 
# 

って具合で、アップデートされてないと出てくるので、念のためもう一度アップデートを実行させてみたところ、

# portmaster -ad
===>>> Gathering distinfo list for installed ports

===>>> Starting check of installed ports for available updates
===>>> Checking ports for recursive 'make config'
===>>> Launching child to update python-2.5,2 to python-2.6,2

===>>> Port directory: /usr/ports/lang/python
===>>> Gathering dependency list for lang/python from ports
===>>> Starting recursive 'make config' check
===>>> Recursive 'make config' check complete for lang/python

===>>> Returning to update check of installed ports


===>>> Starting build for ports that need updating <<>> Launching child to update python-2.5,2

===>>> Port directory: /usr/ports/lang/python
===>>> Starting check for build dependencies
===>>> Gathering dependency list for lang/python from ports
===>>> No dependencies for lang/python
===>  Cleaning for python-2.6,2

===>  Extracting for python-2.6,2
===>  Patching for python-2.6,2
===>  Configuring for python-2.6,2
===>>> Creating a backup package for old version python-2.5,2

===>>> Starting check for runtime dependencies
===>>> Gathering dependency list for lang/python from ports
===>>> Starting dependency check
===>>> Dependency check complete for lang/python

===>  Installing for python-2.6,2
===>   Generating temporary packing list
===>  Checking if lang/python already installed
===>   Registering installation for python-2.6,2
===>  Cleaning for python-2.6,2

===>>> Upgrade of python-2.5,2 to python-2.6,2 succeeded

===>>> Returning to update check of installed ports

===>>> Update check of installed ports complete
===>>> The following actions were performed:
	Upgrade of python-2.5,2 to python-2.6,2

# 

一応、終っているっぽいです。最後にもう一度確認のため、portmaster -Lを実行してみたところ、

	===>>> There are no new versions available

となり、またさらに、

# portversion -vL=
[Updating the pkgdb  in /var/db/pkg ... ** Database file locked. Waiting.
** Stale lock file was found. Removed.
- 68 packages found (-1 +1) (...). done]
# pkgdb -aF
--->  Checking the package registry database
# portversion -vL=
# 

となって、何も吐き出さなくなったので釈然としないながらも、こればっかり触っているわけにもいかないので、解決としました。
そろそろ7系に上げた方が良いのかな。安定しているから後一年くらいはこのまま動かしていきたいところですが。

No comments yet

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中

%d人のブロガーが「いいね」をつけました。